12月 102019
 

久しぶりにWordPressを触っております。

新しい記事を書こうとしましたら、以下のポップアップが表示されました。

 

 

内容はこうです。

Failed to load plugin url: https://blog.trippyboy.com/wp-content/plugins/syntax-highlighter-compress/tinymce/langs/ja.js

どうやら、syntax-highlighter-compressというプラグインの中の「ja.js」というファイルが読み込めないために発生しているようです。

似た事象の問題が下記記事で同様の問題の解決方法が説明されていたためです。
【WordPress】Failed to load plugin url: /wp-content/plugins/post-snippets/tinymce/langs/ja.js というエラーが表示されました

さて、厳密にいうと異なるプラグインなのですが原因は同じようです。

下記手順を実行し修正した以降、同様のポップアップは表示されなくなりました。
手順としては、en.jsをja.jsとしてコピーした後、ファイル内の「en」を「ja」に変更しました。

[root@trip langs]# pwd
/[WEB公開ディレクトリ]/wp-content/plugins/syntax-highlighter-compress/tinymce/langs
[root@trip langs]#
[root@trip langs]# ls -la
total 16
drwxrwxr-x 2 apache apache 67 Sep 16 2015 .
drwxrwxr-x 3 apache apache 95 Sep 16 2015 ..
-rw-r--r-- 1 apache apache 65 Sep 16 2015 de_DE.js
-rw-r--r-- 1 apache apache 65 Sep 16 2015 en_en.js
-rw-r--r-- 1 apache apache 63 Sep 16 2015 en.js
-rw-r--r-- 1 apache apache 65 Sep 16 2015 en_US.js
[root@trip langs]#
[root@trip langs]#
[root@trip langs]# cp -p en.js ja.js
[root@trip langs]#
[root@trip langs]# cat ja.js
tinyMCE.addI18n({en:{
shc:{
desc : 'Insert an RSS Feed'
}}});
[root@trip langs]#
[root@trip langs]#
[root@trip langs]# vim ja.js
[root@trip langs]#
[root@trip langs]# ls -al
total 20
drwxrwxr-x 2 apache apache 80 Dec 10 14:21 .
drwxrwxr-x 3 apache apache 95 Sep 16 2015 ..
-rw-r--r-- 1 apache apache 65 Sep 16 2015 de_DE.js
-rw-r--r-- 1 apache apache 65 Sep 16 2015 en_en.js
-rw-r--r-- 1 apache apache 63 Sep 16 2015 en.js
-rw-r--r-- 1 apache apache 65 Sep 16 2015 en_US.js
-rw-r--r-- 1 apache apache 63 Dec 10 14:21 ja.js
[root@trip langs]#
[root@trip langs]# diff en.js ja.js
1c1
< tinyMCE.addI18n({en:{
---
> tinyMCE.addI18n({ja:{
[root@trip langs]#

以上です。

 

コメント大歓迎!質問も受け付けておりますヽ(*´∀`)ノ

%d人のブロガーが「いいね」をつけました。