4月 062011
 
シェアする

インストール済みのパッケージの情報を確認するには こちら のページで説明した方法があるが、まだインストールしていないけど手元に持ってきたRPMパッケージの情報を確認するにはどうしたらいいのだろうか。

-p(Packageの意味) を -q(Queryの意味) と共に使用し、対象となるパッケージを指定してあげれば確認が可能だ。
まだインストールしていないRPMパッケージの情報を参照するには以下のように実行する。

# rpm -qip openssh-4.3p2-41.el5_5.1.i386.rpm
Name        : openssh                      Relocations: (not relocatable)
Version     : 4.3p2                             Vendor: CentOS
Release     : 41.el5_5.1                    Build Date: Mon Sep 13 01:00:45 2010
Install Date: (not installed)               Build Host: builder17.centos.org
Group       : Applications/Internet         Source RPM: openssh-4.3p2-41.el5_5.1.src.rpm
Size        : 744754                           License: BSD
Signature   : DSA/SHA1, Mon Sep 13 01:30:28 2010, Key ID a8a447dce8562897
URL         : http://www.openssh.com/portable.html
Summary     : The OpenSSH implementation of SSH protocol versions 1 and 2
Description :
SSH (Secure SHell) is a program for logging into and executing
commands on a remote machine. SSH is intended to replace rlogin and
rsh, and to provide secure encrypted communications between two
untrusted hosts over an insecure network. X11 connections and
arbitrary TCP/IP ports can also be forwarded over the secure channel.

OpenSSH is OpenBSD's version of the last free version of SSH, bringing
it up to date in terms of security and features, as well as removing
all patented algorithms to separate libraries.

This package includes the core files necessary for both the OpenSSH
client and server. To make this package useful, you should also
install openssh-clients, openssh-server, or both.
#

手元のRPMパッケージをインストールする為に他に必要なパッケージの確認は -R(Requireの意味) を付けて、以下の方法で確認が可能だ。

# rpm -qRp openssh-4.3p2-41.el5_5.1.i386.rpm
/sbin/nologin
audit-libs >= 1.0.8
config(openssh) = 4.3p2-41.el5_5.1
initscripts >= 5.20
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libcom_err.so.2
libcrypt.so.1
libcrypto.so.6
libfipscheck.so.1
libgssapi_krb5.so.2
libk5crypto.so.3
libkrb5.so.3
libnsl.so.1
libnss3.so
libnss3.so(NSS_3.2)
libnss3.so(NSS_3.3)
libnss3.so(NSS_3.4)
libnss3.so(NSS_3.6)
libnss3.so(NSS_3.9)
libnss3.so(NSS_3.9.2)
libplc4.so
libresolv.so.2
libresolv.so.2(GLIBC_2.0)
libresolv.so.2(GLIBC_2.2)
libselinux >= 1.27.7
libutil.so.1
libz.so.1
openssl >= 0.9.8e
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
#

また、これからインストールするRPMパッケージがどのような機能を提供するかを確認するには –provide(Provideの意味) を付けて、以下のように実行しよう。

# rpm -qp --provides openssh-4.3p2-41.el5_5.1.i386.rpm
config(openssh) = 4.3p2-41.el5_5.1
openssh = 4.3p2-41.el5_5.1
#

 

このエントリーをはてなブックマークに追加

コメント大歓迎!質問も受け付けておりますヽ(*´∀`)ノ